MapLink pre-requisites

MapLink 6.2.*

.Net Framework version (for all GIS platforms):

  • .Net framework 3.5 SP1 AND .Net framework 4.5.2. The MapLink installer checks for the presence of the required framework versions.
  • Please talk to your product consultants to check if there is any doubt about the availability of both .Net frameworks on the target machines.

for ArcGIS

  • ArcGIS Desktop version 10.3 or later, including 10.6, licensed at Basic (previously called ArcView) or higher level. NB MapLink 6.2.* does not support ArcGIS 10.7 - this support is coming in a future release.
  • Note for GISquirrel users: GISquirrel may be installed on the same machine, but the MapLink multi-user editor will interfere with GISquirrel's editor.

for MapInfo Professional

MapInfo Professional version 10.0 or later. If using MapInfo version 15.*, it is necessary to use the 32-bit version (find out more).

for QGIS

QGIS 3.4.13


MapLink 6.1.3349

.Net Framework version (for all GIS platforms):

  • .Net framework 3.5 SP1 AND .Net framework 4.5.2. The MapLink installer checks for the presence of the required framework versions.
  • Please talk to your product consultants to check if there is any doubt about the availability of both .Net frameworks on the target machines.

for ArcGIS

  • ArcGIS Desktop version 10.3 or later, including 10.6, licensed at Basic (previously called ArcView) or higher level. NB MapLink 6.1.3349 does not support ArcGIS 10.7 - this support is coming in a future release.
  • Note for GISquirrel users: GISquirrel may be installed on the same machine, but the MapLink multi-user editor will interfere with GISquirrel's editor.

for MapInfo Professional

MapInfo Professional version 10.0 or later. If using MapInfo version 15.*, it is necessary to use the 32-bit version (find out more).

for QGIS (formerly Quantum GIS)

QGIS 2.18.20 through to 2.18.26.  32-bit or 64-bit version. Note: not QGIS 2.18.27 and above, and not QGIS 3.* - this support is coming in a future release. 


MapLink 5 & 6 up to 6.0.2781

.Net Framework version (for all GIS platforms):

  • Up to MapLink version 5.0.2017: .Net framework 3.5 SP1. NB this version does not support ArcGIS 10.4.
  • Later releases (including those supporting ArcGIS 10.4): .Net framework 3.5 SP1 AND .Net framework 4.5.2. The MapLink installer checks for the presence of the required framework versions.
  • Please talk to your product consultants to check if there is any doubt about the availability of both .Net frameworks on the target machines.

for ArcGIS

  • ArcGIS Desktop version 9.3.1 or later, licensed at Basic (previously called ArcView) or higher level. NB MapLink 6.0.2781 (and earlier) does not support ArcGIS 10.6 - this support is coming in the next release.
  • Note for GISquirrel users: GISquirrel may be installed on the same machine, but the MapLink multi-user editor will interfere with GISquirrel's editor.

for MapInfo Professional

MapInfo Professional version 10.0 or later. If using MapInfo version 15.*, it is necessary to use the 32-bit version (find out more).

for QGIS (formerly Quantum GIS)

QGIS 2.14.7 or later, 64-bit version. Note: not QGIS 2.18.* - this support is coming in the next release.


MapLink 4

for ArcGIS

  • ArcGIS Desktop version 9.3.1 or later, licensed at Basic (previously called ArcView) or higher level.
  • .Net Framework version:
    • If using ArcGIS 10.3 or earlier... .Net framework 3.5 SP1
    • If using ArcGIS 10.4... .Net framework 4.5.2

(GISquirrel may be installed on the same machine, but the MapLink multi-user editor will interfere with GISquirrel's editor.)

for MapInfo Professional

MapInfo Professional version 7.0 or later. If using MapInfo version 15.*, it is necessary to use the 32-bit version (find out more).

.Net Framework version 3.5SP1

 

Modified 12/01/2020 by Crispin Flower
Find out more